[Resolved] Website and Billing Portal Down

Started on September 24, 2021 at 3:06 PM. Resolved after about 8 hours

Affected

Billing / Ordering Portal
  • Investigating
    September 24, 2021 at 3:06 PM

    We are currently investigating this incident.

  • Identified
    September 24, 2021 at 3:19 PM

    We are being hit by a Denial of Service attack on the website. We are working on mitigation.

  • Monitoring
    September 24, 2021 at 3:20 PM

    We implemented a fix and currently monitoring the result.

  • Resolved
    September 24, 2021 at 11:23 PM

    The DDoS attack has been mitigated.