Hostodo - DET01 & TPA01 Degraded Network Performance – Incident details
Report an issue
Get updates
Email
Slack
Microsoft Teams
Google Chat
Webhook
RSS
Atom
API
Report an issue
Get updates
Experiencing partially degraded performance
DET01 & TPA01 Degraded Network Performance
Identified
Degraded performance
Started about 5 hours ago
Affected
DET01 (Detroit, MI)
Degraded performance from 1:41 PM to 12:00 AM
TPA01 (Tampa, FL)
Degraded performance from 1:41 PM to 12:00 AM
Updates
Subscribe
Email
Webhook
Identified
May 26, 2026 at 5:40 PM
Identified
May 26, 2026 at 5:40 PM
We are continuing to work on a fix for this incident.
Investigating
May 26, 2026 at 1:41 PM
Investigating
May 26, 2026 at 1:41 PM
We are currently investigating this incident.